Server Requirements

You must be running WordPress 3.1 or higher, PHP5.4 or higher, and MySQL 5 or higher.

Recommended PHP Configuration Limits: many issues that you may encounter, for example, cannot update new version, cannot login admin T-shirt eCommerce, the selected product shows blank and so on…All these issues relate to low PHP Configuration Limits. The solution is to increase the PHP. You can do this by yourself or asking your website admin.

Please sure your server is supported:

  • allow_url_fopen = on
  • memory_limit = 128M
  • post_max_size = 100M
  • upload_max_filesize = 100M
  • Server supported JSON
  • enable ‘ZipArchive’
  • Allow write files
  • parse_ini_file = on
  • CURL
  • simplexml_load_file

Allow writable folders and subfolder:

  • tshirtecommerce/cache
  • tshirtecommerce/data
  • tshirtecommerce/uploaded

Note: Step by step sure your server

  1. Create file info.php
  2. Add content to this file:
    <?php echo phpinfo(); ?>
  3. Upload to your host folder-your-site/info.php
  4. Open link yoursite.com/info.php and check all options.

If your server is not supported, please call to host manager and ask support.